Ask, reply and learn. Join the community of Akaunting.

New Discussion

Dashboard not wotking and number problems

Andrej Jovanovic   ( User )

Commented 5 years ago


I updated to last version of akaunting and tried to make new revenue income. I made new curency and set it default with curency rate of  1.00000000.

I entered 4200 and it saved the amount as 420 000 000. Like it was multiplied with 10 000. It does the same when I make new expense. After I added income and expense my dashboard broke. Probably beacuse, and this is the weird part, my bank account shows my total of 4 100 which is supposed to be as my expense was 100.

What could cause the problem and inconsistency?

Denis Duliçi   ( Admin )

Commented 5 years ago

Hello Andrej. You should set the currency rate as 1, not 1.00000000.

Andrej Jovanovic   ( User )

Commented 5 years ago

Hello Denis,

I set currency rate as 1 but this is what I get when I save the currency

So I guess it is the same problem like when I add an expense or income.




Denis Duliçi   ( Admin )

Commented 5 years ago

I just tried on a new installation but was not able to reproduce such a problem. You can try to delete it and create a new one:

Andrej Jovanovic   ( User )

Commented 5 years ago

Hi, i deleted db and akaunting and installed it again with fresh db. This is the default situation that I get with the curency settings

I later added Hrvatska again. As you can see, by default my curencies have 8 decimal points. And after adding kuna I was still having the same problems. But then i tried with dollars and dollars were working fine.

This is 4500 amount for dollars and 3501 for kn. Then I went to debug things and realized that something is wrong with the currency code for kuna (HRK). I am not sure what do you do with this but here is what I tested.

Since dollar works I renamed dollar curency to kuna and left the dollar code and it still worked normal. It's rate was 1.00000000 so I realized that it should also work when I switch the code to HRK because I ment it was just suppose to add a currency prefix or postfix, but when I changed dollar curency to HRK the amounts again started to multiply and I got same reesult as from above picture. So this probably is the issue. Have you had similar problems before with currency codes? If not this should probably go on github issues.


Commented 5 years ago

Same error here on invoice

GUF 1 € 100.000,00 € 100.000,00

Subtotal: € 100.000,00

GR VAT: € 24.000,00

Total: € 12,40


Stefan Ilivanov   ( User )

Commented 5 years ago

2 New installations on localhost with PHP 7.1 and on (with PHP 7.0, Litespeed cache Off) - currency changes to 1.000000, and in products inventory operator should enter then as 0.0022 EURO, to get final price as 22 EURO. Invoices don't work with such prices, shows 0 everywhere.


Detailed info for the enviroment:


PHP Settings:

Setting Value
Safe Mode Off
Open basedir None
Display Errors Off
Short Open Tags On
File Uploads On
Magic Quotes Off
Register Globals Off
Output Buffering On
Session Save Path /tmp
Session Auto Start 0
XML Enabled Yes
Zlib Enabled Yes
Native ZIP Enabled Yes
Disabled Functions show_source, system, shell_exec, passthru, exec, popen, proc_open
Multibyte String (mbstring) Enabled Yes
Iconv Available Yes
Maximum Input Variables 1000


Linux 3.10.0-614.10.2.lve1.4.55.el7.x86_64 #1 SMP Tue Jun 20 08:59:12 EDT 2017 x86_64
Database Version 10.1.24-MariaDB-cll-lve
Database Collation latin1_swedish_ci
Database Connection Collation utf8mb4_general_ci
PHP Version 7.0.26
Web Server LiteSpeed
WebServer to PHP Interface




Stefan Ilivanov   ( User )

Commented 5 years ago

Database structure is fucked up by the installer of 1.1.6


Currency table on Rate record shows Double 15,7 instead of INT , Items table, Invoices.... everything is fucked up, changed those doubles to INT 11 and everything seems fine.... 


Better release asap as bug fix release of those

Currency - RATE

Items - 



or every table.....

in Payments the same situation

(yeah whole database - search, verify and replace)

Finally good looking and properly calculated invoice -

Unfortunatelly, I should abandon translation and support forums for Bulgarian and Macedonian users... looks like no one watching those forums and have to look for another option or fork


Horia Ungurean   ( User )

Commented 4 years ago

this issue is still not solved in 1.2.5. is to bad...the app is very good!

Miguel Quina Ribeiro   ( User )

Commented 4 years ago

Just figured out, that one needs to swap the Decimal mark and the thousands separator in the Settings > Currency, and it worked for me.

Please login or register to leave a response.

Showing 1 to 10 of 12 discussions