Forum

(2/2) QueryException & (1/2) PDOException -> no .env file

Posted in CategoryInstallation & Update
  • Andreas Reiterer    ( User ) 1 year ago

    Hello!


    I just tried to install Akaunting (my hosting package fulfills all the requirements). 


    I created a mysql database with a user that has all permissions. It seems that the setup can first connect to the database, because it creates some tables in there. 


    But on step 3 of the setup, I get two errors. It says


    SQLSTATE[28000] [1045] Access denied for user 'forge'@'localhost' (using password: NO) (SQL: insert into `ak_companies` (`domain`, `updated_at`, `created_at`) values (, 2018-03-11 18:06:11, 2018-03-11 18:06:11))


    From what I've found in my research, the setup should create a .env file where apparently also the database credentials should be stored. But in my case, there is no .env file (I can see the .htaccess file too, so dot files are not hidden) 


    Is there a chance that I missed something to configure?


    Thanks in advance! 


    Andreas

  • Andreas Reiterer    ( User ) 1 year ago

    Update: In the meanwhile, I tried to create the .env file with the database credentials on my own. 


    Akaunting now thinks it is installed, and shows the login screen. But login is not possible, since there is no table ak_users in my database. I guess that's what happens in the last step of the setup. 


    Is there a way to find out, what happens in my setup? Log files or something?


    Thanks!


    Andreas


     


    PS: I found this log file in storage/logs/laravel.log: https://pastebin.com/JuxqQHK0

  • Ahmet Kurucan    ( User ) 1 year ago

    It seems your installation was corrupted. I would advise to delete everything and start again.

  • Andreas Reiterer    ( User ) 1 year ago

    Thank you for the hint! It turned out, that the issue was that I copied the files directly from "Finder" (Mac OS) into FileZilla. By default, Finder does not show dot-files, so I did not copy .htaccess and .env.example at the first tries. 


    Now that all files are on my webserver, the setup has worked! 


    Thanks!

  • Denis Duliçi    ( Admin ) 1 year ago

    Thank you Andreas for sharing the solution with us, much appreciated ;)

Please login or register to leave a response.