Forum

Ask, reply and learn. Join the community of Akaunting.

New Discussion

Error: Could not connect to the database! Please, make sure the details are correct.

Devon Raymond   ( User )

Commented 4 years ago

What really happen here? Can someone tell how to solve this?
Error: Could not connect to the database! Please, make sure the details are correct.

Sebastian Di Luise   ( User )

Commented 4 years ago

Please explain step by step how you end to that error, might be easy to try to help.


https://akaunting.com/docs/installation

Azmi M   ( User )

Commented 4 years ago

Hi Sebastian, Im facing this issue as well but Im using Akaunting version 1.1.5.


It keep on asking the database's password eventhough its the correct password.


Is there any requirement for the database id / password we need to follow ?. Was it documented?.

Azmi M   ( User )

Commented 4 years ago

Sebastian, would you mind to share your guide so we can follow you through it.


I like Akaunting, but since the first day I found it I never been successfully install it.


I've install so many CMS & this software a bit tough I think. :)


 

Sebastian Di Luise   ( User )

Commented 4 years ago

Hi Azmi,


But installation steps are quite easy... the only thing I can think about it is asking you the password even you type it right, is that you have a password with "special characters", dont know if still that error happens on some installs.  Try to enter a password like number with letters only (no $ % @ - or any other symbol)


Also, please tell, where are you installing? local Ubuntu installation? Windows? an online hosting site? (each kind of environment has its differences)


Try the last version 1.2.3 if it is possible for you (instead of 1.1.5) and post back each answer/test and will try to help you.

Azmi M   ( User )

Commented 4 years ago

Thank you for your reply. My password is just a plain letters no symbols or numbers at all.


I ran my installation on
CentOS release 6.9 (Final)
Apache/2.2.15 (Unix)
PHP 5.6.12 (cli) (built: Aug 13 2015 23:21:24)
mysql  Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1


As of now I following your advise to use version 1.2.3.
I attached screenshot as well for your view. :)


https://ibb.co/fDAjVd


https://ibb.co/geh9wJ


 

Sebastian Di Luise   ( User )

Commented 4 years ago

 OK, I see two errors... one the first seems to be that you could access the database but your database has a different charset, have you tried utf8bin only instead of utf8mb4.  My installs works fine with utf8-bin only... dont know the other charset (having some issues with utf8mb4 in other systems hosted online, so... you can try to change to utf8 bin or utf8 general ci)


The other error seems to me that you are no entering the right user/pass and/or server ip (sometimes instead of localhost, is a local IP like 192.168.0.xxx, even if it is an online hosting site... there you will need to ask the sysadmin)


For user/pass, root might not be enabled to access... you can try to create a new user/pass specifically for akaunting (that will be more secure for your server, if it is your server) and create a database that this user only has ownership.


 

Azmi M   ( User )

Commented 3 years ago

Thank you Sebastian. Your solution is working. :)

Please login or register to leave a response.

Showing 1 to 8 of 8 discussions