Forum

Ask, reply and learn. Join the community of Akaunting.

New Discussion

Error Installing - CLI not high enough

Buck Turgidson   ( User )

Commented 2 months ago

Hi. I am trying to install on a Site Ground server. Copied the directory up and loaded page in browser. Get:

Error: Ask your hosting provider to use PHP 8.1.0 or higher for both HTTP and CLI.

I confirmed the PHP is 8.1.27.

I then asked them to have a look.

*** Start Support ***
You can use PHP 8.1 via SSH CLI using the alias "php81":

baseos | thebinki.com | [email protected]:~$ php81 -v
PHP 8.1.27 (cli) (built: Dec 22 2023 08:49:59) (ZTS)
Copyright (c) The PHP Group
Zend Engine v4.1.27-dev, Copyright (c) Zend Technologies
with Zend OPcache v8.1.27, Copyright (c), by Zend Technologies
baseos | thebinki.com | [email protected]:~$

I am afraid that default PHP CLI version cannot be changed. I tried to set a custom alias for the PHP binary, however your application does not seem to recognize it. Is it possible to contact the support of Akaunting and ask them on how we can set an alias in the PHP code of the application, so the application starts calling the executable php81 instead of the default PHP version?
*** End Support ***

How would we get this working? Is there a config file? Thanks.
Gary

Please login or register to leave a response.

Showing 1 to 1 of 1 discussions