Forum

Ask, reply and learn. Join the community of Akaunting.

New Discussion

Installation - This site can’t be reached

Chris Wong   ( User )

Commented 4 years ago

I followed the Steps(https://akaunting.com/docs/installation)


1) Download the Akaunting package


 - download Akaunting_1.2.3-Stable.zip from  https://akaunting.com/download


 


2) Unzip the downloaded package.


- unzip Akaunting_1.2.3-Stable.zip


 


3) Upload all the files to your server.


- rename Akaunting_1.2.3-Stable to Akaunting and copy to D:\Akaunting


 


4) Open the link: http://your-domain/akaunting-directory in your browser. It will start the installation wizard.


- key in http://172.16.104.56/D:/Akaunting in google chrome show "This site can’t be reached"


 


 

Sebastian Di Luise   ( User )

Commented 4 years ago

You have some misconfiguration in your apache.  Do you have any other php script working in your apache? if so... what is the apache folder you have published?


What is the Windows WAMP packege you have installed?

Roberts Tate   ( User )

Commented 4 years ago

When any sites show This site can't be reached error it happens most of the times due to dns issues. 


It is an easy fix. Just follow this solution to flush dns.


 



  • Go to Command Prompt by pressing windows key and X and select Command Prompt.

  • Now, just paste these commands one by one and after every command hit enter.

  • Commands: ipconfig /release


ipconfig /all


ipconfig /flushDNS


ipconfig /renew


netsh int ip set DNS


netsh winsock reset


Lastly, just reset your PC or the device and see if it makes any changes.

Chris Wong   ( User )

Commented 4 years ago

Thank for the reply.


Sorry i am new to this, please bear with me


didnt install apache or WAMP.


key in commands and flush dns 


I checked the requirement , 



  • PHP 5.6.4 or higher -  php-7.2.4  installed

  • Database (eg: MySQL, PostgreSQL, SQLite, SQL Server) - MySQL installed

  • Web Server (eg: Apache, Nginx, IIS) - turned on windows features Internal information services & internat information services Hostable Web Core.

  • URL Rewrite (mod_rewrite) - URL Rewrite installed


 


After I turned on windows features Internal information services & internat information services Hostable Web Core. i got this error message.



HTTP Error 404.0 - Not Found


The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.




Most likely causes:



  • The directory or file specified does not exist on the Web server.

  • The URL contains a typographical error.

  • A custom filter or module, such as URLScan, restricts access to the file.




Things you can try:



  • Create the content on the Web server.

  • Review the browser URL.

  • Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.




Detailed Error Information:






















Module    IIS Web Core
Notification    MapRequestHandler
Handler    StaticFile
Error Code    0x80070002






















Requested URL    http://172.16.104.56:80/D:/Akaunting
Physical Path    C:\inetpub\wwwroot\D:\Akaunting
Logon Method    Anonymous
Logon User    Anonymous

 




More Information:


This error means that the file or directory does not exist on the server. Create the file or directory and try the request again.

View more information »


Chris Wong   ( User )

Commented 4 years ago

Control Panel\All Control Panel Items\Administrative Tools\internet informations srevices (IIS) Manager


 


Add website


Site Name: Akaunting


Physical Path: D:\Akaunting


IPD Address: 172.16.104.56


Port: 8080


Host Name: akaunting.com

Chris Wong   ( User )

Commented 4 years ago


HTTP Error 404.3 - Not Found


The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.




Most likely causes:



  • It is possible that a handler mapping is missing. By default, the static file handler processes all content.

  • The feature you are trying to use may not be installed.

  • The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.)

  • If ASP.NET is not installed.




Things you can try:



  • In system.webServer/handlers:

    • Ensure that the expected handler for the current page is mapped.

    • Pay extra attention to preconditions (for example, runtimeVersion, pipelineMode, bitness) and compare them to the settings for your application pool.

    • Pay extra attention to typographical errors in the expected handler line.



  • Please verify that the feature you are trying to use is installed.

  • Verify that the MIME map is enabled or add the MIME map for the Web site using the command-line tool appcmd.exe.

    1. To set a MIME type, use the following syntax: %SystemRoot%\windows\system32\inetsrv\appcmd set config /section:staticContent /+[fileExtension='string',mimeType='string']

    2. The variable fileExtension string is the file name extension and the variable mimeType string is the file type description.

    3. For example, to add a MIME map for a file which has the extension ".xyz": appcmd set config /section:staticContent /+[fileExtension='.xyz',mimeType='text/plain']


    Warning: Ensure that this MIME mapping is needed for your Web server before adding it to the list. Configuration files such as .CONFIG or dynamic scripting pages such as .ASP or .ASPX, should not be downloaded directly and should always be processed through a handler. Other files such as database files or those used to store configuration, like .XML or .MDF, are sometimes used to store configuration information. Determine if clients can download these file types before enabling them.

  • Install ASP.NET.

  • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.




Detailed Error Information:






















Module    StaticFileModule
Notification    ExecuteRequestHandler
Handler    StaticFile
Error Code    0x80070032






















Requested URL    http://172.16.104.56:8080/index.php
Physical Path    D:\Akaunting\index.php
Logon Method    Anonymous
Logon User    Anonymous

 




More Information:


This error occurs when the file extension of the requested URL is for a MIME type that is not configured on the server. You can add a MIME type for the file extension for files that are not dynamic scripting pages, database, or configuration files. Process those file types using a handler. You should not allows direct downloads of dynamic scripting pages, database or configuration files.

View more information »


Sebastian Di Luise   ( User )

Commented 4 years ago

Chris, dont really know http server (IIS) for Windows... but, you have to put the Akaunting unzipped files inside your server http public directory.


I think it might be in c:/inetpub/www/, so try to copy files from D:/Akaunting to c:/inetpub/www/Akaunting.


The other thing is that the directory and files must have read permission for INET_USER, but should be fine if you use default IIS folder.


(also you must be sure that your http server supports php and the other requeriments, would be easy maybe if you install WAMP :-x)

Chris Wong   ( User )

Commented 4 years ago

Thanks Sebastian, 


Still no luck, i will try install wamp


 


http://172.16.104.56:8080/C:/inetpub/wwwroot/Akaunting



HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Denis Duliçi   ( Admin )

Commented 4 years ago

Chris, can you please try the following:


http://172.16.104.56:8080/Akaunting

Chris Wong   ( User )

Commented 4 years ago

Hi Denis, 


get this error



HTTP Error 404.3 - Not Found
 

Please login or register to leave a response.

Showing 1 to 10 of 12 discussions