Ask, reply and learn. Join the community of Akaunting.

New Discussion

local install hangs

Ewald Fernbach   ( User )

Commented 1 year ago

I was able to solve the virtual host problem described in my first post. Now I am stuck at step 3 of the installer. Apparently this seems to be a very common problem.
I followed the advice in this post
i.e. installing from the console and got the following readout:
Setting locale en-GB
Creating database tables
Connecting to database akaunting@localhost:3306
Creating company
Creating admin
Applying the final touches

Apparently the install worked, the database is created and some tables are populated (I can acces the database through phpMyAdmin).
How do I get to the login window in this situation? I.e. which address do I enter in the browser?

Marco Bridge   ( User )

Commented 1 year ago

Ensure you've downloaded the official stable package, not from GitHub, which is in the development stage.

Ewald Fernbach   ( User )

Commented 1 year ago

Thanks Marco for your response. After a solid 10hours of trying to get the ball rolling I already dumped the idea of using akaunting. Your response here sparked me to give it a last try. I followed this protocol step by step and it finally worked. The protocol says to use php 8.0. I have 8.1.
I am using a apache2 virtual host for testing purposes. The protocol says to visit "" to start the setup wizard, in my case I had to direct the brower to .
During the registration process one is asked for an API key which is provided through a link which opens upon clicking below the API key field. This part could be made a little more obvious for console geeks ;-)

Muhammad Shahid   ( User )

Commented 1 year ago

Did anyone face issues of app installation. I have integrated the latest version 3.x but unable to install any app. It throws database connection error after installation progress bar completion

Ewald Fernbach   ( User )

Commented 1 year ago

I was able to install apps without any database error.
Here my setup:
Ubuntu 22.04
MySQL version 8.0.32-0ubuntu0.22.04.2
Apache version 2.4.52

Muhammad Shahid   ( User )

Commented 1 year ago

I am using Windows 11, and for any app throwing error below for example Currency Calculator installation error:

The command C:/xampp/php/php.exe artisan module:install currency-calculator 1 failed.

Exit Code: 1(General error)

Working directory: C:\\xampp\\htdocs\\akaunting



SQLSTATE[HY000] [2002] Unknown error while connecting (SQL: select * from `gfp_modules` where `gfp_modules`.`company_id` = 1 and `alias` = currency-calculator and `gfp_modules`.`deleted_at` is null limit 1)

at C:\\xampp\\htdocs\\akaunting\\vendor\\laravel\\framework\\src\\Illuminate\\Database\\Connection.php:760

// If an exception occurs when attempting to run a query, well format the error

// message to include the bindings with SQL, which will make this exception a

// lot more helpful to the developer instead of just the databases errors.

catch (Exception $e) {

throw new QueryException(

$query, $this->prepareBindings($bindings), $e




1 C:\\xampp\\htdocs\\akaunting\\vendor\\laravel\\framework\\src\\Illuminate\\Database\\Connectors\\Connector.php:70

PDOException::(SQLSTATE[HY000] [2002] Unknown error while connecting)

2 C:\\xampp\\htdocs\\akaunting\\vendor\\laravel\\framework\\src\\Illuminate\\Database\\Connectors\\Connector.php:70

PDO::__construct(mysql:host=;port=3306;dbname=akaunting, root, , [])

Error Output:

Please login or register to leave a response.

Showing 1 to 6 of 6 discussions