Forum

Ask, reply and learn. Join the community of Akaunting.

New Discussion

send invoice as email error

Ricky J   ( User )

Commented 4 years ago

I installed the app in my subdomain and using php mail function, i created one dummy invoice and while trying to send that as an email it redirects to error "oops, look like something went wrong", screenshot attached, rest of all is working fine for me, superb app, 10/ 10 to developers.


I have tried smtp and send mail too, all are giving me the same results, am I making any mistake somewhere??


error screen

Denis Duliçi   ( Admin )

Commented 4 years ago

Ricky, can you plz enable debug and try again https://akaunting.com/docs/developer-manual/debug

Emilio Colombo   ( User )

Commented 4 years ago

Hi! I'm having problems sending invoices by email too.


I have SMTP configured in Settings > General > Email. But when I go to an Invoice and select More actions > Send email, the system throws HTTP ERROR 500.


I have my account created in your servers, so I think I can't enable debug mode (right?).


How can I know if there is a problem with my configuration, my password, my SMTP server, or it's not a problem in my side?


Thanks!

Emilio Colombo   ( User )

Commented 4 years ago

I also noticed that if emails protocol is set to "log", the More actions > Send email also returns an HTTP ERROR 500 :o

Ricky J   ( User )

Commented 4 years ago

still waiting for the solution, I tried my best but I failed in that.

Ahmet Kurucan   ( User )

Commented 4 years ago

Guys, have you enabled debug? What do you get after that?

Adem Ali Durmuş   ( User )

Commented 3 years ago

Could you try set company logo before sending an email.

Nicolas Holmes   ( User )

Commented 3 years ago

another problem is becouse you didn't set the company image profile, it will not send invoice without it or even print

Desmond   ( User )

Commented 2 years ago

I encountered a similar error. This is the result of the debug output:

file_exists(): open_basedir restriction in effect. File(/tmp/log.htm) is not within the allowed path(s): (/home/user/.../:/home/user/tmp)

It seems the app does not have access to the /tmp folder. It would be great if the app can use storage/app/temp instead

Please login or register to leave a response.

Showing 1 to 9 of 9 discussions