Ask, reply and learn. Join the community of Akaunting.

New Discussion

Server Error 500 | Require ext-intl extension

Talina Talina   ( User )

Commented 4 months ago


After updating to Version 3.1.4, I got server error 500.

By enabling the debugging mode, I see this error message:

Class NumberFormatter not exists. Require ext-intl extension. (View: /var/www/*****/*****/resources/views/purchases/bills/index.blade.php)

It's clear that the PHP intl extension need to be enabled and it's already enabled. there was no problems before the update, however I checked again. I tried with diferrent PHP versions, 8.1, 8.2 and intl is enabled in both php.ini and using phpenmod command.

I'm hosting it on my private server, which means there is no hosting company to ask.

Any recommendations to troubleshoot the problem?

Thank you in advance

Scott Carson   ( User )

Commented 3 months ago

Exact same problem here. I went to con fig/app.php and set debug to true, then reloaded the page and everything was fine. That tells me, there was a cache issue and the file change (as irrelevant as it was) was enough to force a reload.

Bottom line: try clearing all caches

Please login or register to leave a response.

Showing 1 to 2 of 2 discussions